Thursday, September 30, 2004

Firefox inroads...

Seen on the interweb at a big corporate site
This Web site is best experienced using Microsoft Internet Explorer (IE) version 5 and above, Mozilla Firefox or Netscape 7 and above.
Get Firefox - the future's here today.
Post a Comment